There are only few system packages maintained by CustomBuild, as most of the Operation System packages are managed by package managers like yum, apt-get or pkg.

General articles about software updates can be found in CustomBuild - Upgrading Services. This one is designed to sort uncommon package manager issues.

Yum generates: repomd.xml [Errno 14] HTTP Error 404: Not Found

If you get something that looks like this when you try and run yum:

https://mirrors.lug.mtu.edu/epel/7/x86_64/repodata/xxyyzz-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
http://mirror.oss.ou.edu/epel/7/x86_64/repodata/xxyyzz-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
https://mirror.csclub.uwaterloo.ca/fedora/epel/7/x86_64/repodata/xxyyzz-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
1
2
3
4
5
6

The solution is to clean yum cache with:

yum clean all
1

and then run the desired yum command again.

Fixing apt-get on Debian

If your apt-get servers are not working correctly for Debian 8, edit /etc/apt/sources.list and set the following:

deb http://debian.mirror.iweb.ca/debian/ jessie main
deb-src http://debian.mirror.iweb.ca/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://debian.mirror.iweb.ca/debian/ jessie-updates main
deb-src http://debian.mirror.iweb.ca/debian/ jessie-updates main
1
2
3
4
5
6
7
8
9

Then type:

apt-get update
1

Once fixed you can run your usual apt-get commands.

How to install cmake

Some services require cmake to be compiled, for example: MySQL 5.6.

We recommend trying to use your system's package manager to install cmake on your system:

CentOS

yum install cmake
1

Debian

apt-get install cmake
1

FreeBSD

pkg_add -r cmake
1

However, if your package manager isn't working, you can still install cmake from source:

cd /root
wget http://files1.directadmin.com/services/custombuild/cmake-3.9.2.tar.gz
tar xzf cmake-3.9.2.tar.gz
cd cmake-3.9.2
./configure
make
make install
1
2
3
4
5
6
7

which should install the cmake binary into /usr/local/bin/cmake, eg:

# /usr/local/bin/cmake --version

cmake version 3.9.2
1
2
3
Extracting mysql-5.6.29.tar.gz ...
Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertion `needed != ((void *)0)' failed!
1
2
Last Updated: 6/23/2021, 9:36:08 PM